Registriere dich hier, um versteckte Bereiche sehen zu können, Highscores zu speichern oder Fragen zu stellen!

Automatische Verkleinerung für Bilder scheint nicht richtig zu funktionieren

Einstellungen, Fragen und Antworten, das Hilfe-Forum für phpBB3 Foren von http://www.phpBB8.de und Forumo!
Kostenloses phpbb2 Forum
phpbb2 Forum Hosting
www.phpbb6.de
phpbb9 ist das Support Forum für unsere Hosting Services.Hilfe nur für Foren von Kostenloses-Forum.be, Userboard.org, plusBB, phpbb8.de, phpbb6.de, Gratis-Board.de und Forumo.de.
Du hast dein Forum nicht bei uns? Dann schaue dich um und siehe was du selbst völlig kostenlos machen könntest, gucke dir auch andere interessante Foren aus unserem Netzwerk an!
Du erhältst hier Tipps und Problemlösungen zu deinem Forum bei uns!

phpbb3
phpBB3 Forum Hosting
www.phpbb8.de
AbonnentenAbonnenten: 1
LesezeichenLesezeichen: 0
Zugriffe: 625

Automatische Verkleinerung für Bilder scheint nicht richtig zu funktionieren

Beitrag#1von Lonie » 08.07.2014 15:05

Hallo ihr Lieben

Ich habe im Forum die Bildgröße auf maximal 640pix (Höhe und Breite) begrenzt.
Leider werden die Bilder teilweise nicht richtig skaliert. Da sind beispielsweise Bilder auf 687px × 1.013px skaliert das ist uns viel zu groß....
Könnt ihr mir nen tipp geben was ich da noch probieren könnte?

Ich habe es bei Allgemein/Beiträge geändert, bei Beiträge/BBcode Box Einstellungen und auch diesen
Code: Alles auswählen
.resize_me img { max-width:640px;max-height:640px; }
code beim Theme des Styles eingegeben.

Ich bin mit meinem Latein am ende.... Ach ja es handelt sich um das Setterforum.

Ich wäre für jeden Tipp dankbar.
Liebe Grüße
Lonie

http://hundegewusel.forumo.de
Style: AcidTech


Und Admin bei
http://settermeute.phpbb8.de/index.php
Style: DirtyBoard2.0
Benutzeravatar
Lonie
eingestellter User
eingestellter User
 
Beiträge: 67
Registriert: 03.2009
Geschlecht: nicht angegeben

Re: Automatische Verkleinerung für Bilder scheint nicht richtig zu funktionieren

Beitrag#2von Lea » 08.07.2014 19:04

Eigentlich ist eine Einstellung im Theme gar nicht nötig.

Du schreibst jetzt leider nicht, wo deine Bilder nicht verkleinert werden.
In den Beiträgen?

Dann kontrolliere doch bitte deine Einstellung im
ACP --> Beiträge --> BBCode Box Einstellungen

Sollten da auch die Einstellungen korrekt sein, kann es nur noch ein Script sein, was das Script der Verkleinerung blockt.
Oder ist ein Script- oder Werbeblocker eingeschaltet. :denk: :denk:
Benutzeravatar
Lea
Lebende Legende
Lebende Legende
 
Beiträge: 21204
Registriert: 02.2016
Geschlecht: nicht angegeben

Re: Automatische Verkleinerung für Bilder scheint nicht richtig zu funktionieren

Beitrag#3von Lonie » 08.07.2014 19:36

Hallo Lea

Ja in den Beiträgen werden die Bilder nicht richtig verkleinert.

Die Einstellungen unter ACP --> Beiträge --> BBCode Box Einstellungen stimmen.

Den Code habe ich nur ins Theme eingefügt weil die Skalierung leider nicht funktioniert.....

Einen Webeblocker nutze ich nicht auf euren Seiten.
Liebe Grüße
Lonie

http://hundegewusel.forumo.de
Style: AcidTech


Und Admin bei
http://settermeute.phpbb8.de/index.php
Style: DirtyBoard2.0
Benutzeravatar
Lonie
eingestellter User
eingestellter User
 
Beiträge: 67
Registriert: 03.2009
Geschlecht: nicht angegeben

Re: Automatische Verkleinerung für Bilder scheint nicht richtig zu funktionieren

Beitrag#4von Lea » 08.07.2014 19:53

Wenn die Verkleinerung trotz deiner korrekten Einstellungen nicht funktioniert, dann kann es nur noch ein Script sein, was du in deinem Forum eingebaut hast, was mit dem Scipt der Bildverkleinerung kollidiert.
Da nützt auch kein Zusatzbefehl im Theme.

Da ich in dein Forum nicht reinschauen kann, ist eine Ferndiagnose recht schwierig.
Nach deiner Beschreibung scheint das Script der Bildverkleinerung in deinem anderen Forum zu funktionieren.
Benutzeravatar
Lea
Lebende Legende
Lebende Legende
 
Beiträge: 21204
Registriert: 02.2016
Geschlecht: nicht angegeben

Re: Automatische Verkleinerung für Bilder scheint nicht richtig zu funktionieren

Beitrag#5von Lonie » 08.07.2014 20:20

Das andere Forum läuft nicht als da zuletzt gepostet wurde gabs meine ich die Einstellung noch das auch verlinkte Bilder nur eine bestimmte Größe haben dürfen. :oops:

Ich danke dir aber trozdem für deinen Versuch mir zu helfen.

Geändert habe ich eingentlich nur das die Shoutbox oben anstatt unten ist und das hier:

Code: Alles auswählen
<!-- IF NEWEST_USER -->
            <div class="forabg2">
         <div class="inner"><span class="corners-top"><span></span></span>
         <ul class="topiclist">
            <li class="header">
               <dl class="icon">
                  <dt>&nbsp;&nbsp;{L_STATISTICS}</dt>
               </dl>
            </li>
         </ul>
         <ul class="topiclist forums">
      <li class="row6">


Dann werden wir wohl Bilder die zu groß sind manuell löschen müßen. :kaffee: :lol:
Liebe Grüße
Lonie

http://hundegewusel.forumo.de
Style: AcidTech


Und Admin bei
http://settermeute.phpbb8.de/index.php
Style: DirtyBoard2.0
Benutzeravatar
Lonie
eingestellter User
eingestellter User
 
Beiträge: 67
Registriert: 03.2009
Geschlecht: nicht angegeben

Re: Automatische Verkleinerung für Bilder scheint nicht richtig zu funktionieren

Beitrag#6von Lonie » 08.07.2014 21:10

Einen Link kann ich dir einstellen aber ich weiß nicht ob ihr da rein könnt.... :denk:
Liebe Grüße
Lonie

http://hundegewusel.forumo.de
Style: AcidTech


Und Admin bei
http://settermeute.phpbb8.de/index.php
Style: DirtyBoard2.0
Benutzeravatar
Lonie
eingestellter User
eingestellter User
 
Beiträge: 67
Registriert: 03.2009
Geschlecht: nicht angegeben

Re: Automatische Verkleinerung für Bilder scheint nicht richtig zu funktionieren

Beitrag#7von Lonie » 08.07.2014 21:19

Nein Melisande ich habe keine BBCodes erstellt....

Ich könnte dir wenn das ok ist ne PN mit den zugangsdaten von meinem Testaccount schicken. Kann das Passwort ja wieder ändern wenn du geschaut hast. ;)
Liebe Grüße
Lonie

http://hundegewusel.forumo.de
Style: AcidTech


Und Admin bei
http://settermeute.phpbb8.de/index.php
Style: DirtyBoard2.0
Benutzeravatar
Lonie
eingestellter User
eingestellter User
 
Beiträge: 67
Registriert: 03.2009
Geschlecht: nicht angegeben

Re: Automatische Verkleinerung für Bilder scheint nicht richtig zu funktionieren

Beitrag#8von Lonie » 08.07.2014 21:38

Ok. Du solltest jetzt in das Thema rein kommen. :blume:
Liebe Grüße
Lonie

http://hundegewusel.forumo.de
Style: AcidTech


Und Admin bei
http://settermeute.phpbb8.de/index.php
Style: DirtyBoard2.0
Benutzeravatar
Lonie
eingestellter User
eingestellter User
 
Beiträge: 67
Registriert: 03.2009
Geschlecht: nicht angegeben

Re: Automatische Verkleinerung für Bilder scheint nicht richtig zu funktionieren

Beitrag#9von Lonie » 08.07.2014 22:13

Hab ich gemacht.
Ich sehe keinen Unterschied. :denk:
Liebe Grüße
Lonie

http://hundegewusel.forumo.de
Style: AcidTech


Und Admin bei
http://settermeute.phpbb8.de/index.php
Style: DirtyBoard2.0
Benutzeravatar
Lonie
eingestellter User
eingestellter User
 
Beiträge: 67
Registriert: 03.2009
Geschlecht: nicht angegeben

Re: Automatische Verkleinerung für Bilder scheint nicht richtig zu funktionieren

Beitrag#10von Lonie » 08.07.2014 22:40

Kein Problem ich bin ja froh wenn mir jemand hilft. :blume:

So, jetzt hat es geklappt :thumbsup: vielen lieben Dank für deine Hilfe. :knuddel:
Liebe Grüße
Lonie

http://hundegewusel.forumo.de
Style: AcidTech


Und Admin bei
http://settermeute.phpbb8.de/index.php
Style: DirtyBoard2.0
Benutzeravatar
Lonie
eingestellter User
eingestellter User
 
Beiträge: 67
Registriert: 03.2009
Geschlecht: nicht angegeben

Re: Automatische Verkleinerung für Bilder scheint nicht richtig zu funktionieren

Beitrag#11von Premium Mitglieder katzentatzen » 19.07.2014 22:46

Vielen Dank Melisande, das konnte ich bei mir auch gebrauchen . :blume:
Benutzeravatar
Premium Mitglieder katzentatzen
Foren-Guru
Foren-Guru
 
Beiträge: 811
Registriert: 10.2010
Geschlecht: weiblich
Deine Foren-URL: www.katzentatzenforum.de
Forenstyle: subsilver2

Re: Automatische Verkleinerung für Bilder scheint nicht richtig zu funktionieren

Beitrag#12von *Headhunter* » 22.12.2014 20:23

Salle,

ich habe auch so ein Problem.
Nachdem ich nun alle Scripte kopiert habe und nach Neuinstallation eines nach dem anderen Checkte, sah ich, dass die Resize-Funktion funktioniert, wenn alles "Normallisiert" ist.

Füge ich mein altes "overall-header"-script wieder ein (unser Logo-Header und Anpassung), werden die Bilder nicht mehr verkleinert.

Fehler-Code war wohl der "Feen-Staub" der vorher funktionierte und keinen Einfluss hatte. nachdem von jemanden eine Änderung durchgeführt wurde, spinnt das Forum.
Den Staub würde ich aber gern bis Sylvester noch nutzen....

Kann hier mal jemand drüber schauen bitte:
Code: Alles auswählen
/* Feenstaub Start */
<script type='text/javascript'>
<!--
var colour="#DF0101"; // Farbe
var sparkles=50;   // Anzahl der Flocken
var x=ox=400;
var y=oy=300;
var swide=200;
var shigh=600;
var sleft=sdown=0;
var tiny=new Array();
var star=new Array();
var starv=new Array();
var starx=new Array();
var stary=new Array();
var tinyx=new Array();
var tinyy=new Array();
var tinyv=new Array();

window.onload=function() { if (document.getElementById) {
  var i, rats, rlef, rdow;
  for (var i=0; i<sparkles; i++) {
    var rats=createDiv(3, 3);
    rats.style.visibility="hidden";
    document.body.appendChild(tiny[i]=rats);
    starv[i]=0;
    tinyv[i]=0;
    var rats=createDiv(5, 5);
    rats.style.backgroundColor="transparent";
    rats.style.visibility="hidden";
    var rlef=createDiv(1, 5);
    var rdow=createDiv(5, 1);
    rats.appendChild(rlef);
    rats.appendChild(rdow);
    rlef.style.top="2px";
    rlef.style.left="0px";
    rdow.style.top="0px";
    rdow.style.left="2px";
    document.body.appendChild(star[i]=rats);
  }
  set_width();
  sparkle();
}}

function sparkle() {
  var c;
  if (x!=ox || y!=oy) {
    ox=x;
    oy=y;
    for (c=0; c<sparkles; c++) if (!starv[c]) {
      star[c].style.left=(starx[c]=x)+"px";
      star[c].style.top=(stary[c]=y)+"px";
      star[c].style.clip="rect(0px, 5px, 5px, 0px)";
      star[c].style.visibility="visible";
      starv[c]=50;
      break;
    }
  }
  for (c=0; c<sparkles; c++) {
    if (starv[c]) update_star(c);
    if (tinyv[c]) update_tiny(c);
  }
  setTimeout("sparkle()", 40);
}

function update_star(i) {
  if (--starv[i]==25) star[i].style.clip="rect(1px, 4px, 4px, 1px)";
  if (starv[i]) {
    stary[i]+=1+Math.random()*3;
    if (stary[i]<shigh+sdown) {
      star[i].style.top=stary[i]+"px";
      starx[i]+=(i%5-2)/5;
      star[i].style.left=starx[i]+"px";
    }
    else {
      star[i].style.visibility="hidden";
      starv[i]=0;
      return;
    }
  }
  else {
    tinyv[i]=50;
    tiny[i].style.top=(tinyy[i]=stary[i])+"px";
    tiny[i].style.left=(tinyx[i]=starx[i])+"px";
    tiny[i].style.width="2px";
    tiny[i].style.height="2px";
    star[i].style.visibility="hidden";
    tiny[i].style.visibility="visible"
  }
}

function update_tiny(i) {
  if (--tinyv[i]==25) {
    tiny[i].style.width="1px";
    tiny[i].style.height="1px";
  }
  if (tinyv[i]) {
    tinyy[i]+=1+Math.random()*3;
    if (tinyy[i]<shigh+sdown) {
      tiny[i].style.top=tinyy[i]+"px";
      tinyx[i]+=(i%5-2)/5;
      tiny[i].style.left=tinyx[i]+"px";
    }
    else {
      tiny[i].style.visibility="hidden";
      tinyv[i]=0;
      return;
    }
  }
  else tiny[i].style.visibility="hidden";
}

function mouse(e) {
  set_scroll();
  y=(e)?e.pageY:event.y+sdown;
  x=(e)?e.pageX:event.x+sleft;
}

function set_scroll() {
  if (typeof(self.pageYOffset)=="number") {
    sdown=self.pageYOffset;
    sleft=self.pageXOffset;
  }
  else if (document.body.scrollTop || document.body.scrollLeft) {
    sdown=document.body.scrollTop;
    sleft=document.body.scrollLeft;
  }
  else if (document.documentElement && (document.documentElement.scrollTop || document.documentElement.scrollLeft)) {
    sleft=document.documentElement.scrollLeft;
   sdown=document.documentElement.scrollTop;
  }
  else {
    sdown=0;
    sleft=0;
  }
}

window.onresize=set_width;
function set_width() {
  if (typeof(self.innerWidth)=="number") {
    swide=self.innerWidth;
    shigh=self.innerHeight;
  }
  else if (document.documentElement && document.documentElement.clientWidth) {
    swide=document.documentElement.clientWidth;
    shigh=document.documentElement.clientHeight;
  }
  else if (document.body.clientWidth) {
    swide=document.body.clientWidth;
    shigh=document.body.clientHeight;
  }
}

function createDiv(height, width) {
  var div=document.createElement("div");
  div.style.position="absolute";
  div.style.height=height+"px";
  div.style.width=width+"px";
  div.style.overflow="hidden";
  div.style.backgroundColor=colour;
  return (div);
}
document.onmousemove=mouse;
-->
</script>
/* Feen Staub Ende */


Danke im Voraus
Ein Noob baute die Arche, Pro's bauten die Titanic...
Benutzeravatar
*Headhunter*
eingestellter User
eingestellter User
 
Beiträge: 53
Registriert: 04.2014
Geschlecht: männlich
Forenstyle: AeroRed

Re: Automatische Verkleinerung für Bilder scheint nicht richtig zu funktionieren

Beitrag#13von Lea » 23.12.2014 16:08

Du hast dir deine Antwort eigentlich schon selbst gegeben. :denk:
Dein Headerscript blockt das Verkleinerungsscript. Das passiert oft bei zweierlei Scripts.
Da wir für Fremdscripts keinen Support geben (dürfen), müsstest du dir überlegen, was dir wichtiger ist:
Die Verkleinerung der Bilder oder dein Header.
Benutzeravatar
Lea
Lebende Legende
Lebende Legende
 
Beiträge: 21204
Registriert: 02.2016
Geschlecht: nicht angegeben


Zurück zu "phpBB3: Hilfestellungen bei der Benutzung"


 

Wer ist online?

Mitglieder in diesem Forum: Google [Bot] und 1 Gast

cron